EXCEL Si 3 conditions, 3 résultats différents [Résolu]

A voir également:Excel si plusieurs conditionsExcel si 3 conditions - Meilleures réponses Plusieurs conditions si excel - Meilleures réponses Formule excel si plusieurs conditions - Conseils pratiques - Excel Fonction SI sur excel avec plusieurs argument ✓ - Forum - Excel Fonction recherche excel avec 2 conditions ✓ - Forum - Excel Excel couleur cellule condition - Conseils pratiques - Excel Excel sommeprod avec condition ✓ - Forum - Excel

Bonjour,

Je suis confronté à un problème sur excel.
J'aimerai trouver le moyen de remplir une cellule avec 3 possibilités de réponse ( "OUI" "NON" ou "N.A." ) , en fonction du texte que je vais écrire dans une autre cellule.

Dans mon cas je veux:
OUI si la cellule ne contient pas de texte (par défaut)
NON si elle contient le lettre N
N.A. si elle contient la lettre B


Dit comme ça cela parait bidon, mais je suis depuis une après midi la dessus!
Aidez moi SVP! =)

Merci d'avance!


Forum

A voir également:Excel si plusieurs conditionsExcel si 3 conditions - Meilleures réponses Plusieurs conditions si excel - Meilleures réponses Formule excel si plusieurs conditions - Conseils pratiques - Excel Fonction SI sur excel avec plusieurs argument ✓ - Forum - Excel Fonction recherche excel avec 2 conditions ✓ - Forum - Excel Excel couleur cellule condition - Conseils pratiques - Excel Excel sommeprod avec condition ✓ - Forum - Excel

Web: www.shapebootstrap.net

3 réponses

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour,

=SI(A1="N"; "NON"; SI(A1="B";"NA";"OUI"))


"Trotti Trotta, Monsieur P, il y a des anges qui veulent un bisou..."
"Même les joujou de Monsieur P ont besoin de joujou"

Dire « Merci » 24

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57816 internautes nous ont dit merci ce mois-ci

Reply
réponses:
  • auteur

    Merci Neliel et chossette9 , grâce à vous j'ai réussi! c'était bien ça.

    c'est fou comme les problèmes se résolvent vite grâce à ce forum! Merci à tous.

    .... je vais quand même essayer de comprendre la formule, histoire de ne plus être confronté à ce problème par la suite.

    thx!

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour,

en supposant que la cellule à tester est A1, on écrit en B1 :

=SI(A1="N";"Non";SI(A1="B";"N.A";SI(ESTVIDE(A1);"Oui";"")))


Cordialement.

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Je vais t'aider à la comprendre, il s'agit en fait de 2 SI imbriqué (pour mon cas)

En français, cela donne:

=SI(A1="N";"NON";SI(A1="B";"NA";"OUI"))

SI la cellule A1 contient "N" alors écrire "NON" SINON SI la cellule A1 contient "B" alors écrire "NA" SINON écrire "OUI"

Reply
réponses:
  • auteur

    Oui mais dans ce cas là, tu ne prends pas en compte la demande OUI si la cellule ne contient pas de texte (par défaut) , c'est pourquoi j'ai imbriqué 3 SI :

    SI A1 contient "N" alors écrire "Non", SINON si A1 contient "B" écrire "N.A", SINON si A1 est vide écrire "Oui", sinon ne rien écrire.

    Cordialement.

  • auteur

    Tu as parfaitement raison... mais tu as fait du zèle! Il n'y avait que 3 possibilités selon son énoncé! ;-)

  • auteur

    Ces 3 possibilités en appelle une quatrième par défaut : Si c'est différent des 3 conditions, alors on ne met rien.

    De toutes façons, les deux solutions fonctionnent.

  • auteur

    Merci Beaucoup ça maaaaaaarcheeeeeeeee

  • auteur

    merci bcp

Leave a Replay

Make sure you enter the(*)required information where indicate.HTML code is not allowed