EXCEL Si 3 conditions, 3 résultats différents [Résolu]

Excel si plusieurs conditions Si excel 3 conditions Plusieurs conditions si excel [excel] condition d'execution de macro (Résolu) » Forum - Programmation Excel condition cellule couleur (Résolu) » Forum - Excel Excel condition sur texte (Résolu) » Forum - Excel Masquer une page excel (condition) (Résolu) » Forum - Programmation Vba excel : condition ne semble pas verifier (Résolu) » Forum - VB / VBA

Bonjour,

Je suis confronté à un problème sur excel.
J'aimerai trouver le moyen de remplir une cellule avec 3 possibilités de réponse ( "OUI" "NON" ou "N.A." ) , en fonction du texte que je vais écrire dans une autre cellule.

Dans mon cas je veux:
OUI si la cellule ne contient pas de texte (par défaut)
NON si elle contient le lettre N
N.A. si elle contient la lettre B


Dit comme ça cela parait bidon, mais je suis depuis une après midi la dessus!
Aidez moi SVP! =)

Merci d'avance!


Forum

Excel si plusieurs conditions Si excel 3 conditions Plusieurs conditions si excel [excel] condition d'execution de macro (Résolu) » Forum - Programmation Excel condition cellule couleur (Résolu) » Forum - Excel Excel condition sur texte (Résolu) » Forum - Excel Masquer une page excel (condition) (Résolu) » Forum - Programmation Vba excel : condition ne semble pas verifier (Résolu) » Forum - VB / VBA

Web: www.shapebootstrap.net

9 réponses

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Merci Neliel et chossette9 , grâce à vous j'ai réussi! c'était bien ça.

c'est fou comme les problèmes se résolvent vite grâce à ce forum! Merci à tous.

.... je vais quand même essayer de comprendre la formule, histoire de ne plus être confronté à ce problème par la suite.

thx!
Cette réponse vous a-t-elle aidé ?  

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour,

=SI(A1="N";"NON";SI(A1="B";"NA";"OUI"))

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour,

en supposant que la cellule à tester est A1, on écrit en B1 :
=SI(A1="N";"Non";SI(A1="B";"N.A";SI(ESTVIDE(A1);"Oui";"")))

Cordialement.

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Je vais t'aider à la comprendre, il s'agit en fait de 2 SI imbriqué (pour mon cas)

En français, cela donne:

=SI(A1="N";"NON";SI(A1="B";"NA";"OUI"))

SI la cellule A1 contient "N" alors écrire "NON" SINON SI la cellule A1 contient "B" alors écrire "NA" SINON écrire "OUI"

Reply
réponses:
  • chossette9

    Oui mais dans ce cas là, tu ne prends pas en compte la demande OUI si la cellule ne contient pas de texte (par défaut) , c'est pourquoi j'ai imbriqué 3 SI :

    SI A1 contient "N" alors écrire "Non", SINON si A1 contient "B" écrire "N.A", SINON si A1 est vide écrire "Oui", sinon ne rien écrire.

    Cordialement.

  • Neliel

    Tu as parfaitement raison... mais tu as fait du zèle! Il n'y avait que 3 possibilités selon son énoncé! ;-)

  • chossette9

    Ces 3 possibilités en appelle une quatrième par défaut : Si c'est différent des 3 conditions, alors on ne met rien.

    De toutes façons, les deux solutions fonctionnent.

  • auteur

    Merci Beaucoup ça maaaaaaarcheeeeeeeee

  • auteur

    merci bcp

Leave a Replay

Make sure you enter the(*)required information where indicate.HTML code is not allowed