CONNEXION ET INSCRIPTION IMPOSSIBLES À WORDPRESS. - Forum Webmastering

CONNEXION ET INSCRIPTION IMPOSSIBLES À WORDPRESS. Se connecter sur whatsApp (Résolu) » Forum - Messagerie Se connecter sur whatsapp » Forum - Mobile Inscription sur messenger [Résolu] (Résolu) » Forum - Hotmail (Outlook.com) Créer un compte messenger sans Facebook sur Windows 10 [Résolu] (Résolu) » Forum - Facebook Messenger Connexion messenger sans facebook » Forum - Facebook Messenger

Bonjour,
suite à un changement de nom de ma base de donné ,

je me retrouve dans l’impossibilité de me reconnecter à mon interface WordPress.

de plus tous les membres du site est du forum sont dans le même cas. et cerise sur le gâteau les inscriptions sont refusées .

dans le concret :si Je tape exprès un faux admin, il me dit que c’est pas correct.

Pareil pour un faux mot de passe.

par contre quand Je tape mes vrais identifiants, il ne me dit pas que c’est incorrect mais ne se connecte pas,

et l’interface me redemande l’admin et mot de passe à chaque fois mais ne se connecte pas.

au niveau de l’inscription à chaque demande ce message s’affiche : ERREUR : inscription impossible… Veuillez prendre contact avec le webmaster !

bien sur j’ai contacté mon hébergeur pour savoir si y n’y avait pas un problème du côté hébergement.

il m’a confirmé qu’il n’y avait aucun problème à ce niveau. et ma proposé quelques pistes standard ,afin de cerner le probleme.

voila les actions que j’ai faitent:

tout d’abord j’ai vérifié s’il n’y avait pas de conflit plugins en désactivant par ftp

ensuite en désactivant le thème .mais sans résultat!

j’ai alors restauré fichiers et base de données (depuis mes sauvegardes d’hébergement )

les tous sans résultat .

Maintenant ne sachant plus quoi faire je me tourne vers vous .merci d’avance si quelqu’un a une idée pour régler ses problèmes.

Forum

CONNEXION ET INSCRIPTION IMPOSSIBLES À WORDPRESS. Se connecter sur whatsApp (Résolu) » Forum - Messagerie Se connecter sur whatsapp » Forum - Mobile Inscription sur messenger [Résolu] (Résolu) » Forum - Hotmail (Outlook.com) Créer un compte messenger sans Facebook sur Windows 10 [Résolu] (Résolu) » Forum - Facebook Messenger Connexion messenger sans facebook » Forum - Facebook Messenger

Web: www.shapebootstrap.net

10 réponses

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour

d'abord quelques questions pour débroussailler le terrain:
est ce que tu as uniquement ce bref message d'erreur ou indique-il une erreur php ou autre ?
la sauvegarde que tu as remise était faite manuellement ou via un plugin ?
est ce que tu as modifié manuellement le fichier wp-config.php lors du changement de nom de base de donnée ?
tu dis que tu as remis les sauvegardes donc est ce que ta bdd et le fichier wp-config.php indiquent bien les bons identifiants ?



Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

bonjour

tout d'abord merci pour ta réponse..

j'ai simplement un message d'erreur pour l'inscription mais pas pour la connexion si non aucun autre message.

Les restaurations que j'ai remises vienne de mon hébergeur (j'ai un forfait avec sauvegarde incluses.).

Lors du changement de nom de la base de données c'est le support de mon hébergeur qui a fait le nécessaire pour faire reconnaitre la base de données.

par contre l'ors de la restauration c'est moi qui est manuellement inscrit le nom de la base de données dans le fichier wp-config.php

tout paraît fonctionner la base de données est reconnue d'ailleurs le site tourne .le gros problème c'est que personne ne peut se connecter ou me inscrire donc je n'ai plus d'accès admis .

je te laisse l'adresse du site si tu veut jeter un oeil merci pour ton aide...

http://www.central-mao.com/

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Je remarque que tu as une ligne de code concernant le slider qui apparait en clair sur ton site, est ce que c'est un code que tu as ajouté manuellement dans un fichier ?

Normalement quand tu édites un fichier en php, tu dois le faire dans un éditeur de code (comme l'excellent notepad++) et surtout pas dans un éditeur de texte (style blocnote) mais cela ne suffit pas, il faut encoder le fichier au bon format hors la plupart des éditeurs encode nativement en utf8 alors que wordpress a besoin d'un encodage en utf8 (sans bom) .

Bref, si tu t'est contenté de modifié le fichier et de l'enregistrer sans te préoccuper de l'encodage, c'est peut être ce qui cause le problème

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour ,elgazar

et merci pour ta réponse !
les codes que tu as vus pour la slide et autres sont gérés par plugin ...j'ai les est désactivés pour refaire une mise à jour 4.9.4 pour vérifier encore une fois les conflits plug et écritures possibles..

en ce qui concerne l'écriture il est vrai que le codage en utf8 (sans bom) est recommandé notamment pour les caractères spéciaux perso je travaille très peu dans le dur mais j'utilise évidemment notepad++
associé à file zilla pour les formats.

Au vu des recherches et viril que j'ai fait à l'heure actuelle:

il me semble qu'a la suite du changement de nom sur la base de données ,qu'il il a eu un conflit de syntaxe (espace ,ligne ,écriture, ou autres ) qui pose
un problème de redirection url sans prise en compte des données de connexion .
les fichiers les plus exposés à mon avis sont : htaccess ..wp config php wp login php .ou alors une résurgence dans un fichier de base de donné.

perso je n'ai pas les compétences pour régler le problème seul .

alors tout propositions, pistes ou idées seront le bienvenu ...merci à vous tous.

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

si c'était les fichiers htacces ou wp-config, l'ensemble de ton site serait impacté . Amha, tu dois avoir un problème à la table qui gère les authentifications (table wp-users).

on va essayer un truc (comme d'hab, sauvegarde toujours avant de commencer)

télécharge sur ton ordinateur le fichier wp-config.php et colle ce code sur la ligne suivante la ligne contenant define db-collate (elle est a la ligne 39 dans n++ donc l'ajout doit etre sur la ligne 40)

define('WP_ALLOW_REPAIR', true);

ensuite va a l'adresse tonsite.tld/wp-admin/maint/repair.php, tu verras que wordpress propose de réparer et d'optimiser les tables, lance le truc et attends le résultat. Si toutes les tables sont correctes, la réparation a été faite, et tu peux enlever la ligne de code du fichier wp-config.php avant d'aller vérifier (enlève le avant sinon tu retomberas sur cette même page)

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

tu as raison c'est à coup sûr un problème de base de données.
j'ai suivi tes indications de mise en place de ('WP_ALLOW_REPAIR', True);
mais ça n'a pas fonctionné
alors je suis rentré directement sur le serveur et sur la base de données
et j'ai cliqué sur réparation base de données .
il refuse de faire l'action et me marque ce message:1142 inserts commandent Demi-to usé .........
Là c'est surement un problème d'autorisation .il faut peut être que je contact mon hébergeur non?

Voyant cela j'ai écrit la commande devine('WP_DEBUG', dans le fichier wp-config.php .
et la hop il m'a signalé une erreur sur une table de la base de données.me confirmant que la table
( bat wsd plugin alerts) avait un problème à priori de mise à jour ainsi que les fichiers qui en font partie..

le message fait deux pages donc trop long pour le poster ici mais voila la phrase principal répété pour chaque erreur:

(erreur de la base de données:UPDATE commande denied To usé central [email protected] for table bat wsd plugin

en verifiant uniquement la table concerné ; (bat wsd plugin alerts). voila le message qui est donné:

(Il y a des problèmes avec les index de la table `bat_wsd_plugin_alerts .Les index PRIMARY et alertId_UNIQUE semblent identiques et l'un d'eux pourrait être supprimé.)`)

je ne comprends pas bien le message et surtout quoi faire pour régler cela tu as peut-être une idée ?
en tout cas merci à toi pour le coup de main!!!

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

wsd est le prefixe de ta base??

est ce que ce ne serait pas simplement que ta bdd est remplie par ces alertes et du coup plus aucune action n'est possible

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

non , le préfixe de la table c'est " bat" et le nom de la table c'est : bat_wsd_plugin_alerts.

au sujet du volume de la base de données j'ai 1go de dispo et je suis loin de les remplir.
de plus mon hebergeur est censé me prévenir quand la base est pleine.

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

en gros le message signifie que tu n'a pas l'autorisation de faire des updates sur cette table , il faut voir qui utilise cette table et comment est fait la requète pour l'updater

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour,

J'ai pu enfin comprendre et résoudre mon problème en travaillant sur ma BD je me suis aperçu que je n'avais plus d'autorisation
De correction ou autre. j'ai donc contacté le support de mon hébergement pour leur demander une autorisation full sur ma base de données.

Une fois que j" ai eu la main j'ai pu annaliser toutes mes tables et effectuer une réparation .À la suite de cela, tout est rentré dans l'ordre

Merci .elgazar ..... Pour m'avoir donné un coup de main.

Je pense qu'on peut clore ce poste ... Problème résolut.. Merci

Reply

Leave a Replay

Make sure you enter the(*)required information where indicate.HTML code is not allowed