Création d'un script shell et exécution [Résolu] - Ubuntu

A voir également:Création d'un script shell et exécutionCréation html par script shell ✓ - Forum - Shell Exécution d'un script shell avec CygWin ? ✓ - Forum - Shell Erreur lors de l'exécution d'un script shell ✓ - Forum - Linux / Unix Execution script shell avec php ✓ - Forum - Shell Executer un script shell - Conseils pratiques - Shell

Bonjour à tous

Très heureuse de vous revenir, bien que ma journée ne soit pas très bonne.
Je travaille en ce moment sur un projet sur l'OS Linux : Ubuntu et il me faut connecter deux machines virtuelles avec ssh, distribuer à chacune des deux une les clé privé/publique et ensuite écrire un script shell sur l'une des machines qui devra être exécuté par l'autre. Le script devra principalement servir à éteindre l'autre mv à un moment précis.

J'ai déjà fait les 3/4 du projet en je but sur la création du script shell ainsi que les commandes qui devront me servir à éteindre l'autre machine (genre j'ai MV1 et MV2. MV1 contient un script shell qui devra être envoyé à MV2 avec comme instruction "éteins-toi MV2 à 10h00"). Je suis néophyte en ce qui concerne l'univers Linux et j'avoue que je n'ai même pas d'idée sur où commencer.

Toute assistance serait la bienvenu et merci d'avance !

Forum

A voir également:Création d'un script shell et exécutionCréation html par script shell ✓ - Forum - Shell Exécution d'un script shell avec CygWin ? ✓ - Forum - Shell Erreur lors de l'exécution d'un script shell ✓ - Forum - Linux / Unix Execution script shell avec php ✓ - Forum - Shell Executer un script shell - Conseils pratiques - Shell

Web: www.shapebootstrap.net

2 réponses

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Salut,

Si la partie clé privée/publique est en place et fonctionnelle, une simple connexion ssh suivie de la commande adéquate devrait suffire amplement ;-)

ssh [email protected]_machine 'shutdown -h now'


Bien évidemment, le compte "xxx" devra avoir les droits nécessaires pour éteindre ladite machine.

Reply
réponses:
  • auteur

  • auteur

    Bonjour UnGnU
    Merci de m'avoir répondu aussi vite

    Déjà j'ai essayer avec cette commande mais dès que je valide, c'est la mv courante qui s'éteint et non l'autre.

    En plus, je souhaite plutôt automatisé les choses, de sorte que je n'ai pas besoin de me connecter à la MV2 chaque fois et de taper la commande pour qu'elle s'éteigne. Il faudrait que la tâche soit automatique, genre chaque jour à 22h00, le script contenant la commande pour éteindre la MV2 est exécuté et celle-ci est immédiatement éteinte, sans mon intervention.

    C'est d'ailleurs pour ça que je parle d'écrire un script shell qui le fera

  • auteur

    Déjà j'ai essayer avec cette commande mais dès que je valide, c'est la mv courante qui s'éteint et non l'autre.
    Tu dois mal t'y prendre. Je viens de refaire un test chez moi (avec la commande
    hostname -s
    à la place de
    shutdown
    , et c'est bien le nom de la machine distante qui s'affiche et non celui de la machine d'où est lancée la connexion ssh.

    De plus cette commande
    ssh autre_machine 'shutdown -h now'
    est idéale puisqu'il suffit de configurer la crontab avec juste cette commande en paramètre pour que l'action désirée (extinction) de la machine se fasse à l'heure voule.

  • auteur

    Désolée de déranger autant, mais c'est quoi la crontab??

  • auteur

    L'ordonnanceur de tâches sous GNU/Linux.
    Voir crontab

  • auteur

    Un exemple concret serait la bienvenue stp

  • auteur

    Test depuis un raspberry pi dénommé "pi-ole".
    En gras les commandes, en italique le résultat des commandes.

    Je lance la commande "

    hostname -s
    " (qui renvoie le nom de la machine) depuis le PC pi-ole :
    [email protected] ~ $ hostname -s
    pi-ole

    Je lance maintenant une connexion ssh vers un autre PC (dénommé brikabrak) avec en paramètre la commande "
    hostname -s
    " :
    [email protected] ~ $ ssh -p 2224 [email protected] 'hostname -s'
    brikabrak

    Le nom renvoyé est bien celui de la machine distante. Donc la commande a bien été exécutée sur la machine distante et non sur la machine locale.

  • auteur

    D'accord
    Donc si je t'ai bien compris, quand je lance les deux mv, sur l'une je tape la commande

    hostname -s
    pour avoir le nom de la machine et ensuite je tape
    ssh -p "port de connexion" [email protected] 'nomdelavmactuelle'
    c'est ça??

  • auteur

    Salut,

    et ensuite je tape
    ssh -p "port de connexion" [email protected] 'nomdelavmactuelle'
    c'est ça??
    Non ! Tu tapes :
    ssh -p "port de connexion" [email protected]  'hostname -s'

    Et la commande
    hostname -s
    devrait te retourner le nom de la machine distante.

  • auteur

    Ohhhhh d'accord

  • auteur

    Bonjour UnGnU
    J'espère que tu vas bien.

    Je suis désolée de revenir aussi tard. Hier en essayant de taper la commande que tu m'as proposé plus haut, j'ai eu une erreur. Après avoir fait quelques recherches, deux ou trois forums disaient qu'ils fallait désinstaller le serveur ssh sur les deux mv et les ré-installer, ce que j'ai fait. Mais lorsque j'essaie d'établir une nouvelle connexion avec la méthode d'authentification par clés privés/publiques, il génère bien la clé.

    Quand je tape donc la commande

    ssh-copy-id -i id_rsa.pub [email protected]
    , il me demande d'entrer un mot de passe qui est normalement celui de la machine actuelle(à moins que je ne me trompe) . Mais ça m'affiche,
    Permission denied, try again
    .

    Au bout de trois essais, il m'affiche
    Permission denied (Public key,password)

    J'ai encore fait des recherches là dessus, mais rien qui résolve mon problème.
    Donc voilà là où j'en suis.

    Je vous prie de m'aider si quelqu'un a une idée
    Merci d'avance !

  • auteur

    Salut,

    il me demande d'entrer un mot de passe qui est normalement celui de la machine actuelle(à moins que je ne me trompe)
    Oui si cet utilisateur existe sur l'autre machine en ayant le même mot de passe ;-\

  • auteur

    Merci pour ta réponse, mais en fait j'ai recommencé le système d'authentification à zéro et donc l'autre mv n'avait pas encore cet utilisateur existant chez lui.
    Je le fait sur une mv et ensuite sur l'autre

  • auteur

    Bonsoir
    J'attend toujours une réaction s'il vous plaît !

  • auteur

    Ben ta dernière réponse ne nous dit pas si tu as avancé ou pas ;-\

  • auteur

    Non Non
    J'en suis au même point
    Toujours le

    Permission denied, try again please

  • auteur

    Regarde dans le fichier

    /etc/ssh/sshd_config
    si la directive
    PasswordAuthentication yes
    est bien décommentée et à "yes".

  • auteur

    Je l'ai vérifiée tantôt et elle est bien à yes

  • auteur

    Elle est bien décommentée (pas de dièse (#)en début de ligne) ?

  • auteur

    et décommentée (voici exactement ce qui s'affiche

    #PasswordAuthentication yes

  • auteur

    Ben justement, ça ne va pas :-((

    Enlève le dièse devant la ligne, sauvegarde et relance le daemon :

    sudo systemctl restart sshd

  • auteur

    Ok je viens de le faire et ça me ramène vers mon prompt. Je relance la procédure d'authentification par ssh, c'est ça?

  • auteur

    Oui.

  • auteur

    Hello zipe31
    Je viens de réessayer de connecter les deux machines en générant les clés, mais ça bloque au même niveau. Dès qu'il me demande le password, il refuse celui que j'entre toutes les trois fois

  • auteur

    Désolé pour toi, mais là perso j'ai fait le tour de mes compétences ;-(

  • auteur

    OOOhhhhh lala, il ne me reste plus que mes petits yeux pour pleurer alors.

    Merci énormément de m'avoir aidé quand même

  • auteur

    Quand tu fais un copy-id c'est l'user/mdp de la machine distante qu'il faut renseigner.
    Exemple :

    ssh-copy-id -i id_rsa.pub [email protected]_machine_distante
    puis entrer mdp_machine_distante.

    Ça devrait mieux marcher :)

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Salut,

Juste un truc auquel je n'avais pas pensé... lors de la génération des clés, as-tu mis une passphrase ?

Si oui, c'est cette passphrase qu'il te faut donner lorsque le mot de passe t'es demandé.

Reply
réponses:
  • auteur

  • auteur

    Bonjour UnGnU
    Oui j'ai mis une passphrase et j'ai aussi essayer avec la passphrase lorsque le mdp m'a été demandé, mais le résultat est pareil

  • auteur

    Si tu veux que ton script soit automatique il ne faut pas mettre de passphrase (c'est sécurisé mais je ne connais pas d'autre manière de faire)

  • auteur

    Bonjour Danelectro
    En réalité vu que je suis bloqué au niveau de la génération des clés pour l'authentification, je n'ai même pas encore écrit de script (ce sur quoi je n'ai même pas encore d'idée).
    Alors, ce que tu me conseilles de faire c'est de réessayer la génération de clés pour l'authentification mais cette fois ci en ne mettant pas de passphrase??

  • auteur

    Oui, en gros tu vas faire :

    Génération des clés dans /home/ton_user/.ssh (sans passphrase)

    $ ssh-keygen
    ¹
    Copie de ta clé publique sur la machine distante pour permettre la connexion sans mdp (basée sur [email protected]) - on te demandera le mot de passe de la machine distante²
    $ ssh-copy-id [email protected]_machine_distante

    Pour le script c'est tout simple, comme l'a dit @UnGnU, tu ouvres un éditeur de texte (nano), tu y écris :
    #!/bin/bash
    ssh [email protected]_machine_distante 'shutdown -h now'

    Puis tu l'enregistres et tu fermes nano (
    Ctrl+O > nom_du_script.sh > Ctrl+X
    )

    Pour tester :
    $ ./nom_du_script.sh


    Pour en faire une tâche planifiée :
    $ crontab -e

    Tu y entres :
    0 22 * * * /chemin/vers/ton/script.sh

    Ca veut dire "exécute le script à 22h00 quelque soit le jour, le mois, et le jour de la semaine".
    Tu fermes nano comme tout à l'heure et voilà !


    ¹ N'écris pas le
    $
    , c'est pour représenter ton prompt
    ² ssh-copy-id est en fait un script qui se connecte en SSH à la machine distante et copie ta clé publique dans .ssh/authorized_keys, il a donc besoin de ta clé publique (par défaut : ~/.ssh/id_rsa.pub), et du login/mdp de la machine distante

  • auteur

    D'accord
    J'y vais tout de suite je te reviens stp

  • auteur

    Hello Danelectro

    J'ai finalement réussi à générer une clé publique que j'ai copier dans la machine distante. Le prompt de la machine distante s'est affiché et j'ai fait la commande

    sudo shutdown -h now
    pour voir si la machine distante s'éteint et elle s'est éteinte.
    Je suis donc revenu au prompt de la machine actuelle et j'ai continuer en créant le script pour éteindre à machine à distance
    J'ai donc fait la commande
     sudo gedit script_shutdown.ssh

    Ce qui m'a ouvert l'éditeur de texte où j'ai taper
    ssh [email protected]_machine_distante 'shutdown -h now'
    , j'ai enregistrer et puis j'ai fermé l'éditeur.
    Je reviens donc au prompt et je fait la commande
    ./nom_du_script.sh


    Je reçois une belle erreur qui est
    bash: ./script_shutdown.ssh : Permission denied


    Du coup je me demande si je ne devais pas rester connecté à la machine distante et y créer le script??

  • auteur

    Je reviens donc au prompt et je fait la commande
    ./nom_du_script.sh
    Avant de lancer le script, il faut le rendre exécutable :
    chmod +x nom_du_script.sh
    et comme tu l'as créé via gedit et au nom du superutilisateur, tu devras sûrement devoir rajouter sudo devant la commande
    chmod
    ;-\

    Et avant d'en faire un script, il serait plus raisonnable et judicieux de tester l'effet en direct, non ?

    Directement depuis ton prompt :
    ssh [email protected]_machine_distante 'shutdown -h now'

  • auteur

    Ok merci
    Je vais réessayer

  • auteur

    Oups pardon j'ai oublié ce détail, merci UnGnU !
    Par contre éviter d'utiliser

    sudo
    quand ce n'est pas nécessaire.
    Un petit
    sudo chown ton_user ton_fichier
    et c'est réglé.

    Dernière chose, habituellement l'extension des scripts bash est .sh. Techniquement ça ne change rien de l'appeler .ssh, mais ce n'est pas une bonne pratique.

  • auteur

    Ok. Bien noté Danelectro

  • auteur

    Alors, voici ce que je reçois comme message après avoir tapé la commande

    ssh [email protected]_machine_distante 'shutdown -h now'


    Failed to set wall message, ignoring : interactive authentification required

    Failed to power off system via logind : interactive authentification required

    Failed to start poweroff.target : interactive authentification required

    See system logs ans 'systemctl status poweroff.target' for details

    Failed to open /dev/initctl: permission denied

    Failed to talk to init daemon.

  • auteur

    Oups j'ai oublié le sudo devant la commande

    shutdown
    ;-(

    Par contre, si tu dois donner le mot de passe pour sudo sur ta machine distante, ce n'est pas encore gagné ;-(

  • auteur

    Je viens de refaire avec le sudo et il me demande le mot de passe de la machine actuelle, ce que j'ai entré, ensuite il me demande de valider la connexion, je saisi "yes" et ensuite il me demande le mot de passe de la machine distante, ce que je saisi encore, puis il renvoi la même suite d'erreur que ci-haut (la suite de failed en haut).

  • auteur

    Voila ce que tu dois taper :

    ssh logi[email protected]_machine_distante 'sudo shutdown -h now'

  • auteur

    Je suis profondément désolée de déranger autant, mais cette fois ça affiche autre chose

    no tty present and no askpass program specified

  • auteur

    Ça c'est normal : si tu exécute une commande à distance tu n'es sur aucun tty (terminal virtuel). Il faut rajouter l'option

    -t
    , mais comme tu veux automatiser, il faut faire autrement (cf. mon précédent message).

  • auteur

    Hmm, j'avais pas pensé à ça. Plusieurs solutions : soit t'exportes ta clé publique sur le compte root de la machine distante (ce qui permet à ton utilisateur local de se connecter en root sur la machine distante sans mdp), ça implique d'autoriser la connexion en root sur la machine distante (/etc/sshd.conf je crois), mais je le déconseille fortement pour des raisons de sécurité ;
    soit tu édites le fichier sudoers (commande

    visudo
    ) pour permettre à un utilisateur non-root d'exécuter shutdown sans mdp (le but étant d'automatiser l'extinction, on veut se débarrasser du prompt de mdp).

    Sur ta machine distante :
    $ sudo visudo

    Tu y entres à la fin :
    ton_user ALL=(ALL) NOPASSWD:/sbin/shutdown

    Tu enregistres, tu fermes le fichier et tu testes.

  • auteur

    Hello
    Quand je modifie le fichier sudoers en rajoutant la commande demandée à la fin du fichier, je fais ensuite ctrl+X pour fermer, il me demande si je souhaite enregistrer, je fais "y(=yes)". Ensuite il m'affiche une suite de commande genre

    Append
    ,
    MAC format
    ,
    DOS format
    , etc...
    Je ne sais trop quoi choisir

  • auteur

    Tu l'édites avec quel programme ? Ctrl+X c'est pour nano, mais si tu utilises autre chose c'est probablement différent. Sinon essaie "o" à la place de "y".

  • auteur

    Je le fait avec nano.
    Et apparement je viens d'effectuer une mauvaise manip, parce que j'ai réussir à faire exit, il m'affiche ensuite

     >>> /etc/sudoers: syntax error near line 31 <<<
    sudo : parse error in /etc/sudoers near line 31
    sudo : no valid sudoers sources found, quitting
    sudo : unable to initialize policy plugin

  • auteur

    Re-

    Affiche la sortie de cette commande :

    sudo sed -n 31p /etc/sudoers

  • auteur

    Contente de te revoir zipe31
    Avec la commande que tu propose, ça affiche la même chose (même erreur que ci-dessus)

  • auteur

    Allô Allô???

  • auteur

    Bonjour à vous
    Voilà, j'ai pu réparer le fichier sudoers. Je n'obtiens d'erreurs

  • auteur

    Tu as bien édité en tapant

    visudo
    ? Ce programme sert justement à t'empêcher d'enregistrer un fichier sudo erroné.

  • auteur

    Bonjour Danelectro
    Oui c'est bien cette commande que j'ai tapé hier.

    Mais bon, je l'ai finalement réparé en suivant les instructions du lien fourni par zipe31 ci-dessus.

    Sauf que je ne suis toujours pas sorti de l'auberge, vu que je n'ai toujours pas de script automatique me permettant d'éteindre la mv distante. Je commence un peu à désespérer !

  • auteur

    Le script pour l'instant on s'en fiche. Il faut faire les choses dans l'ordre.
    1- Créer les clés SSH
    2- Copier les clés sur la machine distante
    3- Donner les droits à l'utilisateur de lancer la commande shutdown sans mot de passe
    4- Tester la commande via ssh
    5- Si test OK, créer un script
    6- Tester le script
    7- Si script OK, automatiser

    Quand chaque étape sera validée, tu auras ton script.

    Si l'étape 3 est validée, on teste l'étape 4 :

    ssh [email protected]_machine_distante 'sudo shutdown -h now'

  • auteur

    Bonjour UnGnU
    Par rapport à l'étape 3, c'est celle qui consiste à modifier le sudoers file pour y permettre à un sudo admin d'éteindre sans mot de passe??

    Si oui, comme je l'ai réparé, il faudrait que je le modifie à nouveau avec la commande

    ton_user ALL=(ALL) NOPASSWD:/sbin/shutdown
    ??

  • auteur

    Oui.
    En éditant le fichier via la commande

    sudo visudo
    .
    Et en y rajoutant la directive
    ton_user ALL=(ALL) NOPASSWD:/sbin/shutdown
    en fin de fichier.

  • auteur

    Ok
    Je le refait, en espérant que je ne bousille pas le fichier une fois de plus. Dit, stp, le

    ton_user
    est celui de la machine distante pour laquelle j'édite le fichier ou bien est celui de la machine actuelle (celle qui tente d'éteindre la distante)??

  • auteur

    Celui de la machine distante qui doit exécuter la commande

    shutdown
    , qui doit être le même normalement que
    ssh login_machine_distante@ip_machine_distante
    ;-_

  • auteur

    D'accord
    Et stp, pour enregistrer, je fait bien Ctrl+X, Y Enter ou bien??

  • auteur

    Si ton éditeur par défaut (celui qui ouvre visudo) est bien nano, oui c'est bien ça.

  • auteur

    Ca a marché. la machine distante a bien été éteinte. Ensuite, on passe à l'étape 5, c'est ça??

  • auteur

    Oui. Voir le post de Danelectro pour le contenu du script. Avant de le lancer pour tester, n'oublie pas de le rendre exécutable (

    chmod +x nom_du_script.sh
    )

  • auteur

    Ok.
    Je viens de créer le script et je l'ai rendu exécutable.
    Stp, pour l'étape 6, comment est ce que je procède pour tester le script??

  • auteur

    Dans un terminal, depuis le répertoire où se trouve le script :

    ./nom_du_script.sh <Entrée>

    ou
    /chemin/absolu/vers/nom_du_script.sh <Entrée>

  • auteur

    Une fois encore ça a marché, la machine distante s'est éteinte. Je commence à retrouver le sourire.
    Enfin, c'est l'étape 7. Alors pour automatiser, je fais juste

    crontab -e
    ???

  • auteur

    Oui, comme indiquée par Danelectro plus haut. Change juste l'heure pour tester, style il est 10h38, et tu mets par exemple une programmation pour 11h00 :

    0 11 * * * /chemin/absolu/vers/nom_du_script.sh
    et tu attends sagement 11h00 ;-)

  • auteur

    Alors, quand je fais

    crontab -e
    , il me dit,
     no crontab for username - using an empty one
    et après il m'affiche
    Select an editor. To change later, run 'select-editor' .
    1. /bin/ed
    2. /bin/nano
    3. /usr/bin/vim.tiny

    Choose 1-3 [2]:

  • auteur

    Choisis la 2 (nano)

  • auteur

    Ok. Une petite question stp, si ç la place de

    chemin/absolu/vers/nom_du_script.sh
    ,
    je met
    30 11 * * * ./nom_du_script.sh
    ,
    ça marchera??

  • auteur

    Non. La crontab n'a pas d'environnement et ne saura pas où aller chercher le script.

  • auteur

    D'accord. Sauf que j'ai peur qu'en mettant /home/username/nom_du_script.sh (qui est l'actuel emplacement du fichier) il ne l'exécute pas. ma crainte est dûe au fait que j'ai tout à l'heure fait dans le terminal

     /home/username/nom_du_script.sh 
    , mais ça n'a pas exécuter le script. Il m'a plutôt dit
     No such directory

  • auteur

    Dans un terminal, quand tu es dans le répertoire contenant ton script, que te renvoie la commande

    pwd
    ?

  • auteur

    Elle me renvoie

     /home/username

  • auteur

    Bizarre que

    /home/username/nom_du_script.sh
    ne marche pas ;-(

    T'as pas fait d'erreur dans le nom ?

  • auteur

    Ohhhhhh lala, je suis vraiment bonne pour l'abattoir. J'ai fait une erreur dans le nom tout à l'heure. Je viens de réessayer avec le nom exact et ça marche.
    Merci
    Bon je vais dans le cron voir si on en fini une fois pour toute

  • auteur

    Hello
    Alors dans le cron, j'ai ajouter à la fin du fichier

    45 19 * * * /home/eunice/nom_du_script.sh
    (19h45) en me basant sur l'heure de l'OS ubuntu qui était à 19h43.
    Mais rien n'a été fait et la machine distante est encore allumée.
    Y aurait-il quelque chose qui m'a échappée ou que je n'ai pas bien fait??

    Et stp, j'ai oublier de préciser que lorsque je reviens au terminal, il y a le message
    crontab: installing new crontab
    avant le dernier prompt

  • auteur

    Si le script marche depuis le terminal, il n'y a pas de raison qu'il ne marche pas depuis la crontab ;-(

    As-tu bien tapé le chemin + le nom ?
    As-tu bien fermé la crontab ?

    Affiche son contenu avec la commande

    crontab -l

  • auteur

    Oui, j'ai bien tapé le chemin + le nom
    Oui j'ai bien fermé la crontab
    La preuve est que quand je fais

    crontab -l
    , il affiche bien la liste des tâches cron avec la mienne à la fin de la liste

  • auteur

    Dans ton script, rajoute l'option "-t" à la commande ssh.

    ssh -t [email protected]_machine_distante 'sudo shutdown -h now'

  • auteur

    J'ai réessayer en ajoutant le -t au script et en reprogrammant la tâche cron, mais pareil. La mv distante est encore debout

  • auteur

    Rajoute

    > /home/username/crontab.log 2>&1
    à la suite de ta crontab, pour essayer de comprendre ce qu'il se passe. Ça devrait normalement créer un fichier de log nommé crontab.log dans ton répertoire perso.

    xx yy * * * /home/username/nom_du_script.sh > /home/username/crontab.log 2>&1

    Reprogramme ta crontab à l'heure voulue et après l'heure fatidique affiche le contenu du fichier de log.

  • auteur

    Allô allô??

  • auteur

    Stp, il y a un petit truc qui m'échappe. Est ce normal qu'à l'exécution du script, on me demande encore le mot de passe, avant de pouvoir éteindre la machine distante???
    Ne serait-ce pas peut être ce qui empêche la tâche cron de s'exécuter??

  • auteur

    Est ce normal qu'à l'exécution du script, on me demande encore le mot de passe, avant de pouvoir éteindre la machine distante???
    Non ce n'est pas normal ;-((
    Ne serait-ce pas peut être ce qui empêche la tâche cron de s'exécuter??
    Ben si ;-(

  • auteur

    Bonsoir UnGnu
    J'espère que ça va

    J'ai finalement réussi à résoudre le problème. En fait, la connexion ssh n'avais pas été bonne depuis le début. Lorsque je me connectait à la machine distante, elle continuait à me demander le mot de passe

    J'ai donc tout recommencer dès le début. J'ai supprimer tous les fichiers se trouvant dans le dossier ssh (les clés et le fichier "known hosts").

    Pour commencer, je me suis placé dans le répertoire où est situé le fichier dossier ssh de chaque machine et j'y ai fait la commande

    rm nom_du_fichier
    pour chacun des fichiers se trouvant dans ce dossier.

    Ensuite, j'ai refait le
    ssh-keygen -t rsa
    et j'ai suivi la procédure jusqu'à la fin.

    A la fin, ça a marché nickel.

    J'espère que cette longue discussion pourra aider plus d'un.

    J'envoi plein de remerciements à zipe31, Danelectro et UnGnu pour m'avoir offert leur assistance patiente sur cet exercice.

    Sur ce, je vais marquer ce sujet comme résolu.

    Bonne soirée :-)

  • auteur

    Salut,

    Happy for you. Merci du retour et bonne continuation sur la banquise ;-)

  • auteur

    Dit stp, ne serait-ce pas un problème avec l'heure?? c'est l'heure par rapport à la mv distante qu'il faut renseigner dans la crontab ou bien l'heure par rapport à la mv1(actuelle)??

  • auteur

    Par rapport à la mv1(actuelle)

    Ça ne serait pas plus mal de la mettre à l'heure ;-\

Leave a Replay

Make sure you enter the(*)required information where indicate.HTML code is not allowed