Formule faisant référence à une cellule fixe - Forum VB / VBA

Formule faisant référence à une cellule fixe Formule avec référence à une cellule de la page précédente [Résolu] (Résolu) » Forum - Excel Formule de référence pour autre cellule » Forum - Excel Formule avec référence à des cellules vides » Forum - Bureautique Formule qui fait référence à une cellule au contenu variable (Résolu) » Forum - Excel Modifier une référence de formule dans une sélection de cellules (Résolu) » Forum - Excel

Bonjour,

Dans un tableau, j'ai une ligne de 50 cellules contenant des nombres. Une macro supprime la dernière cellule de la ligne, fait un copier/coller des 49 cellules restantes pour les décaler vers la droite d'une cellule et introduit une valeur dans la première cellule. Jusque là tout va bien.

Dans une autre cellule, une formule calcule la somme de ces 50 cellules soit : =SOMME(B6:AY6).

Lorsque j'effectue ma macro, ma formule est décalée vers la droit et devient = =SOMME(C6:AZ6)

Je pensais qu'en modifiant ma formule comme ceci : =SOMME($B$6:$AY$6), ça solutionnerait le problème mais pas du tout.

J'ai également donné un nom à la plage $B$6:$AZ$6 mais ladite plage nommée est également décalée lors de l'activation de la macro.

Juste pour être complet, calculer la somme sur toute la ligne n'est pas une solution car j'ai simplifié le problème mais je voudrais calculer plusieurs plages (5, 10, 20) sur cette ligne.

Auriez-vous une idée pour solutionner ce problème ?

Merci d'avance.

François


Forum

Formule faisant référence à une cellule fixe Formule avec référence à une cellule de la page précédente [Résolu] (Résolu) » Forum - Excel Formule de référence pour autre cellule » Forum - Excel Formule avec référence à des cellules vides » Forum - Bureautique Formule qui fait référence à une cellule au contenu variable (Résolu) » Forum - Excel Modifier une référence de formule dans une sélection de cellules (Résolu) » Forum - Excel

Web: www.shapebootstrap.net

5 réponses

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour

U exemple de ton fichier serait le bienvenu
Pour transmettre un fichier, il faut passer par un site de pièce jointe tel que cjoint.com

Va sur ce site : http://cjoint.com
Clic sur parcourir,
Cherche ton fichier,
clic sur ouvrir,
Clic sur "Créer le lien cjoint",
Copier le lien,
Revenir ici le coller dans une réponse..

Cordialement

Reply
réponses:
  • auteur

    https://www.cjoint.com/c/HFnmub8iZlZ

  • auteur

    Le premier lien semblait ne pas fonctionner, j'essaie encore : https://www.cjoint.com/c/HFnmCaASDJZ

  • auteur

    Le fichier fonctionne chez moi mais ne fonctionne pas lorsque je le télécharge via Cjoint…

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour

La VBA n’étant pas mon fort j'ai fait transférer ta demande dans le bon forum VBA
Cordialement

Reply

Leave a Replay

Make sure you enter the(*)required information where indicate.HTML code is not allowed