Safari a changé de langue tout seul [Résolu]

A voir également:Safari en anglaisRemettre safari en francais - Meilleures réponses Changer langue safari - Meilleures réponses Safari en anglais comment changer ✓ - Forum - MacOS Barre safari en anglais ✓ - Forum - MacOS Barre outils de SAFARI en Anglais - Forum - MacOS Pourquoi la barre d'outils safari est écrite en anglais ? - Forum - MacOS Problème de safari tout en anglais !!! - Forum - MacOS

Bonjour,
j'ai voulu installer une application via safari mais l'écran est devenu noir et mon macbook pro a redémarré en me demandant si je voulais ré-ouvrir mes pages et j'ai dis non comme à l'habitude. Je suis retournée dans safari mais je me suis rendu compte que safari ainsi que sa barre d'état était en anglais. J'ai essayé de changer la langue en allant dans " préférences système " mais la langue sélectionnée est le français. Je ne sais plus quoi faire pouvez vous m'aidez?



Configuration: Macintosh / Safari 10.1.2

Forum

A voir également:Safari en anglaisRemettre safari en francais - Meilleures réponses Changer langue safari - Meilleures réponses Safari en anglais comment changer ✓ - Forum - MacOS Barre safari en anglais ✓ - Forum - MacOS Barre outils de SAFARI en Anglais - Forum - MacOS Pourquoi la barre d'outils safari est écrite en anglais ? - Forum - MacOS Problème de safari tout en anglais !!! - Forum - MacOS

Web: www.shapebootstrap.net

12 réponses

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour,

Tu peux tenter ceci:
  • quitter l'application Safari
  • ouvrir le dossier "Applications" -> "Utilitaires"
  • lancer "Terminal"
  • dans la fenêtre qui s'ouvre, taper la commande:
    defaults write com.apple.Safari AppleLanguages '(fr)'
  • appuyer sur la touche Entrée ( ↩︎ ) pour exécuter la commande
  • Redémarrer le Mac

Safari devrait être revenu en français

Autre possibilité: utiliser un outil comme Language Switcher qui te permet de faire basculer n'importe quelle application dans n'importe quelle langue, et donc de remettre Safari en français

Ritchi

Dire « Merci » 154

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 59128 internautes nous ont dit merci ce mois-ci

Reply
réponses:
  • auteur

  • auteur

    la premiere solution a bien fonctionné. merci

  • auteur

    j'ai fait la manip et ça bien fonctionne , mais j'ai lue les autre commentaire , et j'ai vue que une personne c'est fait avoir sur une MAJ de adobe flash player, et depuis j'ai eu des problèmes sur safari qui était en anglais , mais je m'eu demande si je suis fait attaque par. se virus, et quoi faire pour éliminer ???

  • auteur

    Merci beaucoup, a très bien fonctionné

  • auteur

    cool j'avais le meme problème est la commande dans le terminal as fonctionné merci merci

  • auteur

    merci ritchi des mois que je galèrais avec ce problème!

  • auteur

    Merci beaucoup pour l'info !

  • auteur

    Merci Ritchi ! Pareillement, des mois que je galère ! Problème résolu OUF! Merci beaucoup !!! (du coup je me suis inscrire sur ce site pour pouvoir répondre et remercier "C'était la moindre des choses" ;-D ) MERCI bcp

  • auteur

    tu me sauves la vie ritchi !!!

  • auteur

    merci beaucoup, safari est de nouveau en français.

  • auteur

    Merci pour ce conseil. Cela fonctionne parfaitement

  • auteur

    Merci pour ce conseil, parfait ! même trop facile !!!!!!

  • auteur

    merci ritchi tu nous sauve

  • auteur

    Coucou... pour moi çà ne marche pas :/ J ai pourtant bien fait comme expliqué plus haut :(

  • auteur

    Bonjour Monsieur Meuble
    Même réponse qu'à toutes les personnes pour lequel cela n'a pas marché: fais une capture d'écran afin que je vois la raison de cet échec.

  • auteur



    Bonjour, j'ai le même souci et le code ne fonctionne pas après moult redémarrages....

  • auteur

    Bonjour chach11,

    Saurais-tu ouvrir une fenêtre Terminal et lancer les commandes afin de connaître l'ordre de préférences des langues mémorisées par ton Mac ?
    Vérification des langues:
    - lance la commande

    defaults read -g AppleLanguages

    - presse la touche "Entrée" (↩︎) du clavier pour activer la commande

    Si tu voies que "en-FR" ou "en-US" dans la réponse:

    Alors fais ceci:
    - lance la commande
    defaults write -g AppleLanguages '("fr-FR", "en-US")'

    - presse la touche "Entrée" (↩︎) du clavier pour activer la commande
    Il faut ensuite redémarrer le Mac : menu Pomme () puis "Redémarrer"

    Note:
    Si tu crains d'avoir un ou des malware(s), alors télécharge et installe dans les Applications Malwarebytes anti-malware (gratuit) puis lance-le et si le scan découvre des malwares alors active l'option de suppression puis redémarre le Mac

    Ritchi

  • auteur

    Bonsoir, j'ai fait toutes les manipulations comme tu as pu nous indiquer, mais mon safari est toujours en anglais. J'ai même fait la manipulation MAJ + CONTROL + COMMAND + R au démarrage et sélectionner le 2e choix de la liste pour tout reconfigurer d'origine mais rien n'y fait. Je me suis fait avoir avec une MAJ d'adobe flasher également.


    Je suis tout nouveau sur MAC donc c'est vraiment galère et ces débuts difficiles ne me facilitent pas la tache .

    Merci pour ton aide

  • auteur

    Salut quel version a tu de Max OS ? car j'avais le même problème , j'étais en Mojave beta j'ai fais une sauvegarde Time Machine , j'ai formater mon MacBook Pro et réinstallé sierra et Safari et en Français puis je suis passer a Mojave , maintenant je sais que des fausse mise a jour flash player

  • auteur

    Je suis exactement dans le même cas que toi : maj d'adobe et depuis safari est passé en anglais... J'ai tout tenté et rien de fonctionne. Je vais tenter l'ultime solution de réinstaller macOS, je te dirai si ça marche...

  • auteur

    Bonjour,
    Avant de tout réinstaller, tu pourrais tenter de supprimer Flash Player (voir ICI) puis de refaire les commandes qui remettent en français Safari.
    Ritchi

  • auteur

    Bonjour natthh
    Voir réponse faite ici:
    https://www.commentcamarche.net/forum/affich-35446135-safari-a-change-de-langue-tout-seul#4
    Ritchi

  • auteur

    Bonjour,
    Après avoir essayé toutes vos propositions, malheureusement sans succès, j'ai trouvé la solution qui a fonctionné pour moi.

    Ouvrir le terminal et taper : open Library
    Ouvrir :
    > Containers
    > com.apple.Safari
    > Data
    > Library
    > Preferences

    Supprimer 'com.apple.Safari.plist'
    Safari va alors se réinitialiser

    Redémarrer le mac

    Et le tour est joué

  • auteur

    Bonjour,
    Votre méthode a parfaitement fonctionné sur un MacBook Air avec macOS Mojave version 10.14.5.
    Alors que les autres méthodes n'avaient pas fonctionné !
    Merci beaucoup :)

  • auteur

    Votre méthode a très bien fonctionné, merci beaucoup !

  • auteur

    Merci Diane ça a marché :D Des mois que je cherchais une solution, merci beaucoup !

  • auteur

    Bravo et merci!!!
    Cela a bien fonctionné pour moi aussi,
    cordialement, Jean-Michel.

  • auteur

    Merci

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonsoir,
Une méthode qui fonctionne c'est d'éliminer toutes les préférences de Safari sans oublier les dossiers qui se trouvent dans la Bibliothèque/Applications Support.

Après élimination Safari revient en Français.

Reply
réponses:
  • auteur

  • auteur

    Bonjour,
    J'ai déjà essayé et ça ne fonctionne pas.
    Par contre, j'ai fait quelques essais supplémentaires.
    J'ai créé un nouvel utilisateur et me suis connecté sous cette nouvelle session.
    Le problème de Safari n'est pas présent.
    Peut-être une solution de contournement pour certains à qui on a dit de réinitialiser leur Mac et que finalement ça n'a pas résolu le problème.

  • auteur

    geswann : Pour info, j'ai trouvé le fichier de préférence Safari qui est vérolé par le weknow sous Mojave (2 min pour supprimer les 2 profils systèmes créés par Weknow, 2h pour la langue Safari a écumer le net...) :

    - Quitte Safari
    - Sous Macintosh HD⁩ ▸ ⁨Utilisateurs⁩ ▸ ⁨(USER) ▸ ⁨Bibliothèque⁩ ▸ ⁨Containers⁩ ▸ ⁨com.apple.Safari⁩ ▸ ⁨Data⁩ ▸ ⁨Library⁩ ▸ ⁨Preferences
    - Supprime le fichier "com.apple.safari.plist"
    - Relance, normalement c'est ok

    En espérant que ça t'aide :)
    A+ Gugli

  • auteur

    Parfait Gugli, super solution, a parfaitement marché pour nous!
    Merci tout plein (y)

  • auteur

    Bonjour Gugli,
    ayant le même problème depuis octobre 2018, merci pour ton info, car le problème est résolu.
    Merci.

  • auteur

    Bonjour, impossible de trouver le cheminement que vous avez proposez ci dessus, comment faire?

  • auteur

    Allez dans le Finder puis cliquer sur "Aller" en haut et si vous ne voyez pas apparaitre la rubrique Bibliothèque cliquer en même temps sur la touche Alt et de là cliquer sur Bibliothèque et aller dans Containers et retrouver le fichier com.apple.safari.plist" et supprimer le puis redémarrer votre PC et normalement safari sera revenu en Français pour moi cela a fonctionner. Par contre j'ai la meme chose avec google et je ne sais pas quel fichier supprimer :(

  • auteur

    Bon avec un peu de mal j'ai enfin réussi la meme chose pour chrome qui était devenu en Anglais. c'est ok c'est revenu en français comme avant.

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

merci beaucoup!!!!

Reply
réponses:
  • auteur

    bonjour,
    pourriez vous me dire comment avez-vous fait pour résoudre le problème ?
    Merci

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Pour info pour ceux qui galèrent encore, j'ai réussi en faisant un copier/coller de la manip à faire dans le terminal.

Reply
réponses:
  • auteur

    ouiiii! Faire un copier coller ! de la phrase donnée par SUPER Ritchie : / default write....'(fr)' / sur son post. Et aller dans utilitaire et terminal. Coller dans la fenêtre qui s'ouvre et faire "enter". Ça faisait quand même 2 mois que je galérai et là oui, c'est le truc qui marche! merci, merci!

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour,

C'était quoi comme application exactement ? Il se peut qu'il s'agisse d'une application prise sur un site douteux et contenant un malware. Faites un contrôle avec MalwareBytes :
https://www.commentcamarche.com/faq/42627-supprimer-adwares-publicite-indesirable-scams-mackeeper-sous-mac-os-x



Reply
réponses:
  • auteur

    Bonjour,
    Je me suis faite avoir avec une MAJ Adobe Flash player et j'ai depuis éliminé le virus weknow.ac.
    Malwarebytes a fait un scann et nettoyé les menaces détectées. Je suis allée vérifier dans les applications et Prefadmin, je n'ai plus rien de malveillant qui apparait.
    Mais la barre Safari reste en anglais...
    Des conseils pour revenir au français ou approfondir la détection d'autre application douteuse ?

  • auteur

    Pareil ! Mon problème a été solutionné par Apple. Il suffit de rentrer un code dans la fonction "Terminal" de ton Mac. Je n'ai pas pensé a le recopier, mais mon soucis est rentré dans l'ordre.

  • auteur

    Je suis dans le même cas que toi, impossible de remettre le français alors que j'ai enfin réussi à supprimer weknow.ac. Qu'as tu fait finalement?

  • auteur

    Comment as tu fais ? Je n'arrive vraiment pas a le supprimer...

  • auteur

    Bonjour Pseudo...
    Je ne comprends pas:
    - le 14 août 2018 à 23:26 tu dis que "la première solution a bien fonctionné" (ndlr: voir ligne de commande citée ici)
    - le 15 août 2018 à 23:37 soit le lendemain tu dis "Je n'arrive vraiment pas a le supprimer..."

    Pourrais-tu en dire plus ?
    Ritchi

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonsoir merci infiniment pour votre aide

le problème est résolu

Reply
réponses:
  • auteur

    bonjour,
    pourriez vous me dire comment avez-vous fait pour résoudre le problème s'il vous plait ?
    Merci

  • auteur

    Bonjour natthh
    En appliquant ce qui est indiqué ici : https://www.commentcamarche.net/forum/affich-35446135-safari-a-change-de-langue-tout-seul#4
    Ritchi

  • auteur

    Hello, bon bah j'ai fait comme indiqué mais safari toujours en anglais depuis maj adobe flash player... grrrr

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjours j'ai le même soucis Avec mon Mac quand je vais dans l'application safari tout est en Anglais
j'ai essayer les conseils donne avec le terminal mais rien de change ..

Reply
réponses:
  • auteur

    Bonjour Sammmm,
    Même réponse qu'à toutes les personnes pour lequel cela n'a pas marché: fais une capture d'écran ou une photo (lisible!!) afin que je vois la raison de cet échec.
    Au cas où, voici une aide sur:
    - Comment faire une capture d'écran
    - Comment partager une capture d'écran ou une photo
    Note1: Sélectionner la partie intéressante et pas l'écran entier sinon l'image sera trop grande et les textes seront illisibles.
    Note2: La capture d'écran doit être au format PNG afin que l'on puisse cliquer dessus pour zoomer dessus: voir explications dans la partie "Images cliquables" du second lien donné ci-dessus.
    Ritchi

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Ayant connu le pb de Safari en Anglais, après avoir bcp galéré, la meilleure solution pour ce qui me concerne a été " Language Switcher " signalé par _Ritchi_ : Simple d'usage, efficace. Merci _Ritchi_

Reply
réponses:
  • auteur

    bonjour,
    J'ai essayé Language switcher qui effectivement me lance Safari en Français. Sauf que...lorsque je ferme et réouvre safari, il est de nouveau en anglais.
    Pour info, j'ai essayé toutes les astuces proposées ici...

    Merci par avance.

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour,
J'ai essayé Language switcher qui effectivement me lance Safari en Français. Sauf que...lorsque je ferme et réouvre safari, il est de nouveau en anglais.
Pour info, j'ai essayé toutes les astuces proposées ici...

Merci par avance.

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

La seule méthode qui a fonctionné pour moi est d'utiliser le logiciel Language Switcher. Le reste n'a pas fonctionné, mais c'est loin d'être parfait. J'ai en gros 2 safaris à présent qui s'affichent et le safari en français est bourré de SPAM. Ca va être pratique. Je vais retourner à ma version en anglais, tant pis.
Merci quand même...

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

merci ça fonctionne en desinstallant adobe flashplayer

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

J’ai eu le même soucis, un logiciel malveillant qui s’est installé ! J’ai contacter le service Apple, il s’est connecté avec moi pour me guider et en moins d’1 heure c’était réglé ! Au prix du Mac, j’voulais pas faire une bêtise ...
c’est leur métier et en plus leur service est gratuit ! Pourquoi se prendre la tête ????
Bravo Apple

Reply

Leave a Replay

Make sure you enter the(*)required information where indicate.HTML code is not allowed