Formule Excel [Résolu] - Forum Excel

A voir également:Formule excelFormule excel si - Conseils pratiques - Excel Formule excel si contient ✓ - Forum - Excel Formule excel - Conseils pratiques - Excel Formule excel si plusieurs conditions - Conseils pratiques - Excel Afficher les formules excel ✓ - Forum - Excel

Bonjour,

S'il vous plaît aidez moi, j'ai cherché mais pour le moment j' ai pas encore trouvé.
J’ai deux colonnes: A1 contenant des codes et B1 des noms et je voudrai associer à chaque nom un code bien spécifique.
Pour la première fois, je veux qu’il ait un libre choix de faire correspondre un code à n’importe quel nom quelconque.
Au fur et à mesure que je remplis les colonnes, Excel mémorise les codes et noms correspondant déjà saisie de telle sorte qu’aucun autre code ancien ne puisse être attribué à un nouveau nom autre que l’ancien.

Par exemple la première fois si je choisis le code C002 au nom Dupon alors la seconde fois si je retape C002 avec un autre nom Alex qu’ Excel ne puis pas le reconnaitre sauf si c’est un nouveau code qui n’a pas été saisie avant.

Forum

A voir également:Formule excelFormule excel si - Conseils pratiques - Excel Formule excel si contient ✓ - Forum - Excel Formule excel - Conseils pratiques - Excel Formule excel si plusieurs conditions - Conseils pratiques - Excel Afficher les formules excel ✓ - Forum - Excel

Web: www.shapebootstrap.net

3 réponses

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour

Pour interdire d'entrer 2 fois le même code en colonne A :
Selectionner toute la colonne A
Données Validation de données
Autoriser Personnalisé
et dans Formule entrer : =NB.SI(A:A;A1)<2

Cdlmnt
Via

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM a aidé 33857 internautes ce mois-ci

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonsoir.

...et pour signaler en rouge les lignes où un même code correspond à 2 noms différents, on peut utiliser la Mise en Forme Conditionnelle.

Une colonne de concaténation des deux premières permet de vérifier s'il y a autant de données identiques en A et en C.

https://www.cjoint.com/c/HHldUNTxv0E

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour,

Merci pour votre assistance, vraiment je suis satisfait.Raymont PENTIER, ta formule repond bien à ce que je cherchais, merci à tous.

Reply

Leave a Replay

Make sure you enter the(*)required information where indicate.HTML code is not allowed