Compte le nombre de jours avant que.... [Résolu] - Forum Excel

A voir également:Compte le nombre de jours avant que....Compter le nombre de jours ouvrés par mois entre deux dates ✓ - Forum - Excel Compter le nombre de jour ✓ - Forum - Bureautique Compter le nombre de jours écoulés ✓ - Forum - Bureautique Compter le nombre de pas par jour - Télécharger - Sport Compter le nombre de [nom du jour] dans une colonne de date ✓ - Forum - Excel

Bonsoir,

J'aimerai savoir si il y a moyen de cherche deux similitude et de compté le nombre de jours avant qu'un nombre soit dépassé?. je pense que le dossier ci-joint sera très clair.

Merci d'avance!!!

https://www.cjoint.com/c/HJstR5HdwLu

Forum

A voir également:Compte le nombre de jours avant que....Compter le nombre de jours ouvrés par mois entre deux dates ✓ - Forum - Excel Compter le nombre de jour ✓ - Forum - Bureautique Compter le nombre de jours écoulés ✓ - Forum - Bureautique Compter le nombre de pas par jour - Télécharger - Sport Compter le nombre de [nom du jour] dans une colonne de date ✓ - Forum - Excel

Web: www.shapebootstrap.net

12 réponses

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonsoir oliris

Avec une simple formule pas évident, mais avec une fonction personnalisée :
https://mon-partage.fr/f/zNBUem22/

Cdlmnt
Via

Reply
réponses:
  • auteur

    Bonsoir Via,

    Je n’obtiens aucun résultat sur le fichier que vous avez envoyé.
    Dois-je encore faire quelque chose avec la Macro.
    Merci d'avoir pris le temps de répondre.
    Bonne soirée.

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Non il faut entrer la fonction dans les cellules comme n'importe quelle fonction Excel selon la syntaxe indiquée
Je l'ai rentrée dans la colonne C e(en rajoutant un SIERREUR pour ne pas avoir un affichage d'erreur quand il n'y a rien en A)
Apparement la macro a disparu dans le fichier envoyé, je te le renvoie
https://mon-partage.fr/f/CwFMIQij/

Par contre si tu changes une valeur dans le tableau de droite tu dois revalider les formules en C pour qu'elles s'actualisent

Bonne soirée également

Reply
réponses:
  • auteur

    Bonjour via,

    Le fichier contient cette fois ci la macro.
    Il y a encore juste un problème:
    Quand j'ouvre le fichier il ne calcule pas, ni quand je change les valeurs.
    Une fois que j'active la cellule avec la formule et que je clique sur "ENTER" alors il calcul correctement cette cellule.
    Est-ce possible de le faire automatiquement?

  • auteur

    Non c'est ce que disais dans mon précédent message il faut revalider les cellules, c'est une fonction (qui se déclenche à son entrée) et pas une macro déclenchée automatiquement

  • auteur

    Bonsoir Via,

    Pour ce que je doit faire, ce n'est par vraiment l’idéale.
    j'ai des centaines de ligne qui doives être calculé.
    Est-ce qu'il n'y a pas d'autre solutions?.
    Dans tout les cas merci beaucoup pour l'aide!!!.

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Re,

Dans ce cas il faut passer par une macro en VBA pour tout actualiser
Poste ton fichier sur mon-partage.fr, fais créer un lien que tu copies et reviens coller ici

Reply
réponses:
  • auteur

    Bonsoir Via,

    Voici le lien vers le fichier: https://mon-partage.fr/f/5QMla1GL/
    J’espère qu'il est asse détaillé.
    J'ai essayé avec formule index et cherche mai sans résultat.
    Merci encore!.

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Re

Finalement puisque ce n'est pas la somme apparement mais le nombre sous un jour qui est déterminant, une simple formule suffit
En C2 mettre : =SIERREUR(EQUIV(B2;DECALER($H$1:$M$1;EQUIV(A2;$G$2:$G$7;0););0);EQUIV(B2;DECALER($H$1:$M$1;EQUIV(A2;$G$2:$G$7;0););1)+1)
A étirer vers le bas

Cdlmnt
Via

Reply
réponses:
  • auteur

    Bonjour Via55!

    Tout d’abord désolé pour mon intervention tardive.
    La formule que tu as envoyé fonctionne parfaitement. Merci beaucoup!.
    Cependant, est-ce que tu penses qu'il est possible d'utilisé la formule avec un premier argument qui demande de calculé à partir d'une date spécifique? (voir fichier sur lien). https://mon-partage.fr/f/eV2whNGN/
    Encore merci, est si pas possible alors tant pis.

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour

Alors en D2 : =SIERREUR(SIERREUR(EQUIV(B2;DECALER($H$1:$M$1;EQUIV(A2;$G$2:$G$7;0););0);EQUIV(B2;DECALER($H$1:$M$1;EQUIV(A2;$G$2:$G$7;0););1));"")-EQUIV(AUJOURDHUI();$H$1:$M$1;0)+ SI(SIERREUR(SIERREUR(EQUIV(B2;DECALER($H$1:$M$1;EQUIV(A2;$G$2:$G$7;0););0);EQUIV(B2;DECALER($H$1:$M$1;EQUIV(A2;$G$2:$G$7;0););1));"")> EQUIV(AUJOURDHUI();$H$1:$M$1;0);1;0)

Cdlmnt
Via

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonsoir Via,

Merci d'avoir totalement résolu mon problème et ma demande.
Je te suis très reconnaissant.
une bonne fin de week-end.

Cordialement,
Oliris.

Reply

Leave a Replay

Make sure you enter the(*)required information where indicate.HTML code is not allowed