Fonction SI [Résolu] - Forum Excel

A voir également:Fonction siFonction si excel - Conseils pratiques - Excel Fonctionnement instagram - Articles Tinder fonctionnement - Articles Snapchat vous a ajouté depuis la fonction - Conseils pratiques - Messagerie instantanée Onduleur fonctionnement - Articles

Bonjour,

Cette formule comporte une erreur mais je trouve pas, pouvez-vous m’aider ?

Merci


=SI(D34=Feuil3!F120;Feuil4!A1;SI(D34=Feuil3!F82;Feuil4!A1;SI(D34=Feuil3!F83;Feuil4!A2;SI(D34=Feuil3!F84;Feuil4!A3;SI(D34=Feuil3!F85;Feuil4!A3;SI(D34=Feuil3!F86;Feuil4!A4;SI(D34=Feuil3!F87;Feuil4!A5;0)))))))+SI(D34=Feuil3!F88;Feuil4!B1;SI(D34=Feuil3!F89;Feuil4!B1))


Configuration: iPhone / Safari 12.1

Forum

A voir également:Fonction siFonction si excel - Conseils pratiques - Excel Fonctionnement instagram - Articles Tinder fonctionnement - Articles Snapchat vous a ajouté depuis la fonction - Conseils pratiques - Messagerie instantanée Onduleur fonctionnement - Articles

Web: www.shapebootstrap.net

6 réponses

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour
quelle est l'erreur signalée? Collée chez moi, cette formule est acceptée sans problème?
à vous lire
crdlmnt

Reply
réponses:
  • auteur

    Merci je teste demain

    Cordialement

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Merci pour votre réponse, l’erreur est #valeur quand je rajoute les 2 derniers arguments, avant elle fonctionne, merci bien

Reply
réponses:
  • auteur

    Alors l'erreur ne vient pas de la formule, mais la valeur définie par les dernières conditions (soit doncFeuil4!B1), car ce défaut vient du fait que vous sommer (via le signe +) des valeurs qui ne sont pas numériques.
    Si c'est une addition que vous voulez faire, il faut que la valeur sélectionnée soit n numérique
    Si par contre vous écrivez ceci pour contourner la limite des 7 SI des anciens Excel (qui n'existe plus à partir de 2007) ce n'est pas le signe + qu'il faut utiliser, mais le signe &

    Mais vous pouvez à partir de 2007 écrire cette formule comme suit:
    =SI(OU(D34=Feuil3!F120;D34=Feuil3!F82);Feuil4!A1;SI(D34=Feuil3!F83;Feuil4!A2;SI(OU(D34=Feuil3!F84;D34=Feuil3!F85);Feuil4!A3;SI(D34=Feuil3!F86;Feuil4!A4;SI(D34=Feuil3!F87;Feuil4!A5;0)))))+SI(OU(D34=Feuil3!F88;D34=Feuil3!F89);Feuil4!B1)

    crdlmnt

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour j’ai utilisé le signe & et curieusement ça marche (bien que j’a utilisé ET sur tous les autres champs du même formulaire, mais mon résultat est précédé de Faux, donc il y a encore un ajustement à faire, qu’en pensez-vous ?

Cordialement

Reply
réponses:
  • auteur

    et quelle est la formule exacte que vous avez écrite
    si le résultat est précédé de FAUX, c'est que c'est la partie après le & qui est active, mais qu'il manque l'option 0 ou "" en fin de la première partie, avant la série de parenthèses avant le &
    soit.....;"")))))&SI(...
    ou.....;0)))))&SI(...
    par contre pour éviter un FAUX dans la seconde partie, il faut aussi p^révoir la fin:
    ........&SI(OU(D34=Feuil3!F88;D34=Feuil3!F89);Feuil4!B1;""')

    crtdlmnt
    .

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

=SI(H33=Feuil3!F120;Feuil4!A2;SI(H33=Feuil3!F82;Feuil4!A4;SI(H33=Feuil3!F83;Feuil4!A4;SI(H33=Feuil3!F84;Feuil4!A6;SI(H33=Feuil3!F85;Feuil4!A6;SI(H33=Feuil3!F86;Feuil4!A8))))))&SI(H33=Feuil3!F87;Feuil4!A10;SI(H33=Feuil3!F88;Feuil4!B2;SI(H33=Feuil3!F89;Feuil4!B2;SI(H33=Feuil3!F90;Feuil4!B4))))

Reply
réponses:
  • auteur

    voir la réponse précédente que j'ai complétée (elle était partie bien avant la fin)
    avec les éléments à rajouter en fin de formule dans les deux parties
    =SI(H33=Feuil3!F120;Feuil4!A2;SI(H33=Feuil3!F82;Feuil4!A4;SI(H33=Feuil3!F83;Feuil4!A4;SI(H33=Feuil3!F84;Feuil4!A6;SI(H33=Feuil3!F85;Feuil4!A6;SI(H33=Feuil3!F86;Feuil4!A8;""))))))&SI(H33=Feuil3!F87;Feuil4!A10;SI(H33=Feuil3!F88;Feuil4!B2;SI(H33=Feuil3!F89;Feuil4!B2;SI(H33=Feuil3!F90;Feuil4!B4;""))))

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

J’ ai rajouté le 0 et un 0 apparaît avant le texte de résultat mais je n’a plus « faux »

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

=SI(H33=Feuil3!F120;Feuil4!A2;SI(H33=Feuil3!F82;Feuil4!A4;SI(H33=Feuil3!F83;Feuil4!A6;SI(H33=Feuil3!F84;Feuil4!A9;SI(H33=Feuil3!F85;Feuil4!A10;SI(H33=Feuil3!F86;Feuil4!A13;""))))))&SI(H33=Feuil3!F87;Feuil4!A16;SI(H33=Feuil3!F88;Feuil4!B2;SI(H33=Feuil3!F89;Feuil4!B4;SI(H33=Feuil3!F90;Feuil4!B5;SI(H33=Feuil3!F91;Feuil4!B7;SI(H33=Feuil3!F92;Feuil4!B10;SI(H33=Feuil3!F93;Feuil4!B12;"")))))))&SI(H33=Feuil3!F94;Feuil4!B14)

Maintenant Faux apparaît après le résultat obtenu, je ne comprends pas pourquoi

Reply
réponses:
  • auteur

    Je recommence:
    chaque ensemble de SI (un avant le & et un après) renvoie FAUX si vous ne lui donnez pas une option au cas où aucune conditions n'est réalisée
    Il faut donc sur chaque ensemble rajouter cette option, comme je l'ai écrit dans mon message ici, une fois

    ;"" 
    derrière le Feuil4!A13 et une fois derrière le dernier Feuil4!B14
    https://www.commentcamarche.net/forum/affich-36025150-fonction-si#8
    et pour ne pas avoir le 0 remplacez le comme proposé par ""

  • auteur

    Merci beaucoup, ça fonctionne, il reste pour moi incompréhensible que ma formule initiale de type SI.....0 + SI fonctionne parfaitement dans tous les champs de mon formulaire et que j’a du la changer dans un seul champ

    Cordialement

Leave a Replay

Make sure you enter the(*)required information where indicate.HTML code is not allowed