Problème avec cellule vide [Résolu] - Forum Excel

A voir également:Problème avec cellule videExcel si cellule vide ✓ - Forum - Excel Mise en forme conditionnelle cellule vide ✓ - Forum - Bureautique Formule excel si cellule vide alors 0 ✓ - Forum - Excel Remplacer cellule vide par 0 ✓ - Forum - Excel Cellule vide vba ✓ - Forum - VB / VBA

Bonjour,
J'ai un tableau qui se rempli avec la fonction RECHERCHEV.
Toutefois, lorsqu'un élément (ici le PU ) manque, il inscrit "0"
Or, j'aurais souhaité qu'il laisse plutôt la case vierge.
Quelqu'un pourrait-il me dire comment procéder ?
Merci d'avance
IEtoQnNNn3Z_Modèle.xlsx


Configuration: Windows / Edge 17.17134



daniel22

Forum

A voir également:Problème avec cellule videExcel si cellule vide ✓ - Forum - Excel Mise en forme conditionnelle cellule vide ✓ - Forum - Bureautique Formule excel si cellule vide alors 0 ✓ - Forum - Excel Remplacer cellule vide par 0 ✓ - Forum - Excel Cellule vide vba ✓ - Forum - VB / VBA

Web: www.shapebootstrap.net

7 réponses

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour à tous,

S'il inscrit 0, c'est parce que ta formule commence par sierreur et se termine par 0)
tu remplaces le 0 par "", a condition que tu dans ta colonne ne fasses pas d'additions dans cette colonne.


Crdlmt

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Merci pour ta réponse, mais si je remplace 0 par "" il m'indique alors #VALEUR!

Reply
réponses:
  • auteur

    Bonjour,

    Un fichier (test) mis sur https://www.cjoint.com/ permettrait de répondre plus précisément à ta question

    Crdmt

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

La case ne sera jamais vierge, puisqu'elle contient une formule.
Et puisque c'est une formule de recherche, elle affichera toujours un résultat.

Et tu as mal utilisé Cjoint.com : Ton lien est vide !

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour

à tenter demander à excel de ne rien inscrire si la cellule PU n'indique rein

=SI(cell PU<>"";formule RECHERCHEV;"")

Cordialement

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Merci pour vos réponses.
Désolé pour le lien vide…..le voici https://www.cjoint.com/c/IEugg1lXwUN

Pour PapyLuc51, ça ne fonctionne pas.

Merci pour votre aide.

Reply
réponses:
  • auteur

    Re:
    C'était une piste sans voir ton tableau. Tu peux soit suivre les indications de Michel_m (salutations) ; soit ruser avec les formules déjà inscrites :

    Rectifier D2
    =SI(RECHERCHEV($F2;$J$1:$L$10;3;0)>0;RECHERCHEV($F2;$J$1:$L$10;3;0);"")

    Rectifier aussi E2
    =SI(D2="";"";B2*D2)

    Cordialement

  • auteur

    Impéccable, cela fonctionne.

    Merci PapyLuc51

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour,

si tu veux absolument que rien n’apparaisse si le prix n'est pas fixé

Reply

Marsh

NOVEMBER 9, 2013 AT 9:15 PM

Bonjour à tous,

Un dernier effort !
https://www.cjoint.com/c/IEuhG6h2vuw

Crdlmt

Reply

Leave a Replay

Make sure you enter the(*)required information where indicate.HTML code is not allowed